linux多版本php配置composer

AndyYang| 阅读:938 发表时间:2022-04-13 13:25:10 composer
摘要:默认composer会和当前的php版本绑定,如果装了多版本php,该如何使用composer呢?
linux多版本php配置composer
默认composer会和当前的php版本绑定,如果装了多版本php,该如何使用composer呢?
我默认的php版本是7.0,后面我再安装了7.4,我想用php7.4版本的composer。

进入php7.4的目录
cd /usr/local/php7.4/bin
curl -S https://getcomposer.org/installer | ./php
即安装成功了php7.4版本的composer

安装tp6
默认安装:
composer create-project topthink/think=6.0.8 tp

新版本的composer安装:
/usr/local/php7.4/bin/php /usr/local/php7.4/bin/composer.phar create-project topthink/think=6.0.8 tp
效果一样,完毕。
本文为AndyYang原创,转载请注明出处!
如果您觉得好,可以打赏作者:
如果您觉得累了,是否想看点美女养养眼:猛戳>>朋友帮
如果您觉得皮了,是否想来点神吐槽:猛戳>>iPhone查询中

已有1条评论

昵称:
邮箱:

  • 最新评论

善良2022-05-18 15:54:27
原则是真/善/忍,修者是做一善良的好人。能救众生于危难之中。
iPhone查询中 - bbs.ipcxz.com 朋友帮 - www.pengyb.cn iPhone查询中 - bbs.ipcxz.com
反馈
微信订阅号